Revision 21 as of 2013-04-06 08:43:48

Clear message
Locked History Actions

Scientific Linux/起動しない

Scientific Linux/起動しない

  • 起動途中で止まる

    • VMware Player 上の Scientific linux 6.3 (64bit) がいつの間にか起動しなくなった。具体的には以下の画面で止まる。
      •  

      • stop.png

      •  

  • 対処

    • vmwlegacy というグラフィックのドライバがちゃんと読めていないことが分かった。/etc/X11/xorg.conf を以下のように編集し、wmware 用のドライバを使うことにする。古い /etc/X11/xorg.conf は一応バックアップを取っておく。
      • Section "Device"
            Identifier     "Device0"
            Driver         "vmwlegacy"
            VendorName     "VMware"
            BoardName      "SVGA II Adapter"
        EndSection
        
        の
            Driver         "vmwlegacy"
        の部分を
            Driver         "vmware"
        に変更。

原因究明の軌跡

  • sevice の起動失敗?

    • Linux のブートをスタートすると、いろいろなサービス(デーモン?)が順番に起動されるが、そこで止まっていないかをまず確認する。通常の起動画面は下図のように、なんのサービスが起動しているかは表示されない。
      •  

      • esc1.png

      •  

    • そこで、上の画面のときにキーボードの Esc キーを押すと、下図のような画面に切り替わり、どんなサービスが立ち上がっているのかを順番に確認することができる。
      •  

      • esc2.png

      •  

    • 結局、下図の画面で止まる。これより、certmonger というサービスで止まっているんじゃないかと疑う。
      •  

      • esc3.png

      •  

    • よって、試しに certmonger を起動しないようにする。具体的には、VMware Player 上の Linux を再起動後、さきほどのバーが出る画面で Esc キーを押し、すぐさま shift + i キーを押す(うまくいかない場合、shift + i を連打してみる)。そうすると、下図のように各々のサービスを起動するか否かを選択できるモード (Interactive mode) になる
      •  

      • shift1.png

      •  

    • とりあえず、certmonger のみを起動しないようにしてみたが、やはり起動の途中で止まる。他のサービスをいろいろ切ってみても、やはり起動しない(下図参照)。よって、サービスの問題ではなく、サービスの起動後に始まる X window system の起動に問題があるのではないかと疑う。
      •  

      • shift2.png

      •  

  • シングルユーザーモード

    • X window system に問題があるとしても、起動が途中で止まるので、確認のしようがない。そこで、シングルユーザーモードで起動を試みる。シングルユーザーモードとは、起動後に root user としてログインしたような状態となるモードであり、多くのサービスが起動されない。具体的には、下図の画面でキーボードの任意のキーを押す。
      •  

      • grub1.png

      •  

    • 下図の画面に切り替わるので、通常使用するイメージを選択状態にし、キーボードの e キーを押す。
      •  

      • grub2.png

      •  

    • そうすると、下図の画面に切り替わる。kernel の部分を選択状態にし、再び e キーを押す。
      •  

      • grub3.png

      •  

    • 下図のように、文末に single と追記し、Enter キーを押し、 b キーを押して、シングルユーザーモードでの起動を開始する。
      •  

      • grub4.png

      •  

    • そうすると、下図のようにシングルユーザーモードのコンソールに行きつく。
      •  

      • single.png

      •  

  • X の設定

    • ここで試しに # startx コマンドを実行すると、下図のように表示され、X は起動しない。
      •  

      • startx1.png

      •  

    • 表示されるメッセージに従い、/var/log/Xorg.0.log を確認してみると、数のように表示される。
      •  

      • startx2.png

      •  

    • どうやら、vmwlegacy というグラフィックのドライバがちゃんと読みこめていないようだ。そこで、Xorg の設定を出来ないかと以下のコマンドを実行してみる。
      • # Xorg -configure
    • そうすると、インストールされているドライバのリストが表示された(下図参照)。
      •  

      • xorg_conf.png

      •  

    • その中に、vmware というドライバがあることを発見した。
    • とりあえず、このドライバを使ってみることにする。/etc/X11/xorg.conf を以下のように編集する。古い /etc/X11/xorg.conf は一応バックアップを取っておく。
      • Section "Device"
            Identifier     "Device0"
            Driver         "vmwlegacy"
            VendorName     "VMware"
            BoardName      "SVGA II Adapter"
        EndSection
        
        の
            Driver         "vmwlegacy"
        の部分を
            Driver         "vmware"
        に変更。
    • 編集後、# startx コマンドを打つと、一瞬 X window system が起動して、終了する。なんとなく問題が解決したような感じになる。 # exit コマンドを打つと、X window system が起動し、下図のログイン画面が表示される。
      •  

      • login.png

      •  

    • 再起動すると、普通に起動し、ログイン画面に行ける。